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Insert rows on a worksheet 

1. Do one of the following: 

To insert a single row, select either the whole row or a cell in the row above which you want to insert the new row. For example, to 

insert a new row above row 5, click a cell in row 5. 

To insert multiple rows, select the rows above which you want to insert rows. Select the same number of rows as you want to insert. 

For example, to insert three new rows, you select three rows. 

To insert nonadjacent rows, hold down CTRL while you select nonadjacent rows. 

How to select cells, ranges, rows, or columns 

TO SELECT DO THIS 

A single cell Click the cell, or press the arrow keys to move to the cell. 

A range of cells Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you press the arrow keys to 

extend the selection. 

You can also select the first cell in the range, and then press F8 to extend the selection by using the arrow keys. To 

stop extending the selection, press F8 again. 

A large range of cells Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can scroll to 
make the last cell visible. 

All cells on a worksheet Click the Select All button.  

 

To select the entire worksheet, you can also press CTRL+A. 

 NOTE   If the worksheet contains data, CTRL+A selects the current region. Pressing CTRL+A a second time selects 

the entire worksheet. 

Nonadjacent cells or cell ranges Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges. 

You can also select the first cell or range of cells, and then press SHIFT+F8 to add another nonadjacent cell or range 

to the selection. To stop adding cells or ranges to the selection, press SHIFT+F8 again. 

 NOTE   You cannot cancel the selection of a cell or range of cells in a nonadjacent selection without canceling the 

entire selection. 

An entire row or column Click the row or column heading. 

 

 Row heading 

 Column heading 

You can also select cells in a row or column by selecting the first cell and then pressing CTRL+SHIFT+ARROW key 

(RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns). 

 NOTE   If the row or column contains data, CTRL+SHIFT+ARROW key selects the row or column to the last used 

cell. Pressing CTRL+SHIFT+ARROW key a second time selects the entire row or column. 
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Adjacent rows or columns Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you select the 
last row or column. 

Nonadjacent rows or columns Click the column or row heading of the first row or column in your selection; then hold down CTRL while you click the 
column or row headings of other rows or columns that you want to add to the selection. 

The first or last cell in a row or column Select a cell in the row or column, and then press CTRL+ARROW key (RIGHT ARROW or LEFT ARROW for rows, 
UP ARROW or DOWN ARROW for columns). 

The first or last cell on a worksheet or in 
a Microsoft Office Excel table 

Press CTRL+HOME to select the first cell on the worksheet or in an Excel list. 

Press CTRL+END to select the last cell on the worksheet or in an Excel list that contains data or formatting. 

Cells to the last used cell on the 
worksheet (lower-right corner) 

Select the first cell, and then press CTRL+SHIFT+END to extend the selection of cells to the last used cell on the 
worksheet (lower-right corner). 

Cells to the beginning of the worksheet Select the first cell, and then press CTRL+SHIFT+HOME to extend the selection of cells to the beginning of the 
worksheet. 

More or fewer cells than the active 
selection 

Hold down SHIFT while you click the last cell that you want to include in the new selection. The rectangular range 
between the active cell and the cell that you click becomes the new selection. 

2. On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Sheet Rows. 

 

 TIP   You can also right-click the selected rows and then click Insert. 

 NOTE   When you insert rows on your worksheet, all references that are affected by the insertion adjust accordingly, whether they are 

relative or absolute cell references. The same behavior applies to deleting rows, except when a deleted cell is directly referenced by a 

formula. If you want references to adjust automatically, it's a good idea to use range references whenever appropriate in your formulas, 

rather than specifying individual cells. 

Tips     

To quickly repeat the action of inserting a row, click the location where you want to insert the row, and then press CTRL+Y. 

If there is formatting, you can use Insert Options to choose how to set the formatting of the inserted rows. 

 

Insert columns on a worksheet 

1. Do one of the following: 

To insert a single column, select the column or a cell in the column immediately to the right of where you want to insert the new 

column. For example, to insert a new column to the left of column B, click a cell in column B. 

To insert multiple columns, select the columns immediately to the right of where you want to insert columns. Select the same 

number of columns as you want to insert. For example, to insert three new columns, you select three columns. 

To insert nonadjacent columns, hold down CTRL while you select nonadjacent columns. 
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How to select cells, ranges, rows, or columns 

TO SELECT DO THIS 

A single cell Click the cell, or press the arrow keys to move to the cell. 

A range of cells Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you press the arrow keys to 

extend the selection. 

You can also select the first cell in the range, and then press F8 to extend the selection by using the arrow keys. To 

stop extending the selection, press F8 again. 

A large range of cells Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can scroll to 
make the last cell visible. 

All cells on a worksheet Click the Select All button.  

 

To select the entire worksheet, you can also press CTRL+A. 

 NOTE   If the worksheet contains data, CTRL+A selects the current region. Pressing CTRL+A a second time selects 

the entire worksheet. 

Nonadjacent cells or cell ranges Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges. 

You can also select the first cell or range of cells, and then press SHIFT+F8 to add another nonadjacent cell or range 

to the selection. To stop adding cells or ranges to the selection, press SHIFT+F8 again. 

 NOTE   You cannot cancel the selection of a cell or range of cells in a nonadjacent selection without canceling the 

entire selection. 

An entire row or column Click the row or column heading. 

 

 Row heading 

 Column heading 

You can also select cells in a row or column by selecting the first cell and then pressing CTRL+SHIFT+ARROW key 

(RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns). 

 NOTE   If the row or column contains data, CTRL+SHIFT+ARROW key selects the row or column to the last used 

cell. Pressing CTRL+SHIFT+ARROW key a second time selects the entire row or column. 

Adjacent rows or columns Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you select the 
last row or column. 

Nonadjacent rows or columns Click the column or row heading of the first row or column in your selection; then hold down CTRL while you click the 
column or row headings of other rows or columns that you want to add to the selection. 

The first or last cell in a row or column Select a cell in the row or column, and then press CTRL+ARROW key (RIGHT ARROW or LEFT ARROW for rows, 
UP ARROW or DOWN ARROW for columns). 

The first or last cell on a worksheet or in 
a Microsoft Office Excel table 

Press CTRL+HOME to select the first cell on the worksheet or in an Excel list. 

Press CTRL+END to select the last cell on the worksheet or in an Excel list that contains data or formatting. 

Cells to the last used cell on the 
worksheet (lower-right corner) 

Select the first cell, and then press CTRL+SHIFT+END to extend the selection of cells to the last used cell on the 
worksheet (lower-right corner). 

Cells to the beginning of the worksheet Select the first cell, and then press CTRL+SHIFT+HOME to extend the selection of cells to the beginning of the 
worksheet. 

More or fewer cells than the active 
selection 

Hold down SHIFT while you click the last cell that you want to include in the new selection. The rectangular range 
between the active cell and the cell that you click becomes the new selection. 
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2. On the Home tab, in the Cells group, click the arrow next to Insert, and then click Insert Sheet Columns. 

 

 TIP   You can also right-click the selected cells and then click Insert. 

 NOTE   When you insert columns on your worksheet, all references that are affected by the insertion adjust accordingly, whether they 

are relative or absolute cell references. The same behavior applies to deleting columns, except when a deleted cell is directly 

referenced by a formula. If you want references to adjust automatically, it's a good idea to use range references whenever appropriate 

in your formulas, rather than specifying individual cells. 

Tips     

To quickly repeat the action of inserting a column, click the location where you want to insert the column, and then press CTRL+Y. 

If there is formatting, you can use Insert Options to choose how to set the formatting of the inserted columns. 

Delete cells, rows, or columns 

1. Select the cells, rows, or columns that you want to delete. 

How to select cells, ranges, rows, or columns 

TO SELECT DO THIS 

A single cell Click the cell, or press the arrow keys to move to the cell. 

A range of cells Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you press the arrow keys to 

extend the selection. 

You can also select the first cell in the range, and then press F8 to extend the selection by using the arrow keys. To 

stop extending the selection, press F8 again. 

A large range of cells Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can scroll to 
make the last cell visible. 

All cells on a worksheet Click the Select All button.  

 

To select the entire worksheet, you can also press CTRL+A. 

 NOTE   If the worksheet contains data, CTRL+A selects the current region. Pressing CTRL+A a second time selects 

the entire worksheet. 

Nonadjacent cells or cell ranges Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges. 

You can also select the first cell or range of cells, and then press SHIFT+F8 to add another nonadjacent cell or range 

to the selection. To stop adding cells or ranges to the selection, press SHIFT+F8 again. 
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 NOTE   You cannot cancel the selection of a cell or range of cells in a nonadjacent selection without canceling the 

entire selection. 

An entire row or column Click the row or column heading. 

 

 Row heading 

 Column heading 

You can also select cells in a row or column by selecting the first cell and then pressing CTRL+SHIFT+ARROW key 

(RIGHT ARROW or LEFT ARROW for rows, UP ARROW or DOWN ARROW for columns). 

 NOTE   If the row or column contains data, CTRL+SHIFT+ARROW key selects the row or column to the last used 

cell. Pressing CTRL+SHIFT+ARROW key a second time selects the entire row or column. 

Adjacent rows or columns Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you select the 
last row or column. 

Nonadjacent rows or columns Click the column or row heading of the first row or column in your selection; then hold down CTRL while you click the 
column or row headings of other rows or columns that you want to add to the selection. 

The first or last cell in a row or column Select a cell in the row or column, and then press CTRL+ARROW key (RIGHT ARROW or LEFT ARROW for rows, 
UP ARROW or DOWN ARROW for columns). 

The first or last cell on a worksheet or in 
a Microsoft Office Excel table 

Press CTRL+HOME to select the first cell on the worksheet or in an Excel list. 

Press CTRL+END to select the last cell on the worksheet or in an Excel list that contains data or formatting. 

Cells to the last used cell on the 
worksheet (lower-right corner) 

Select the first cell, and then press CTRL+SHIFT+END to extend the selection of cells to the last used cell on the 
worksheet (lower-right corner). 

Cells to the beginning of the worksheet Select the first cell, and then press CTRL+SHIFT+HOME to extend the selection of cells to the beginning of the 
worksheet. 

More or fewer cells than the active 
selection 

Hold down SHIFT while you click the last cell that you want to include in the new selection. The rectangular range 
between the active cell and the cell that you click becomes the new selection. 

2. On the Home tab, in the Cells group, do one of the following: 

 

 To delete selected cells, click the arrow next to Delete, and then click Delete Cells. 

 To delete selected rows, click the arrow next to Delete, and then click Delete Sheet Rows. 

 To delete selected columns, click the arrow next to Delete, and then click Delete Sheet Columns. 

 TIP   You can right-click a selection of cells, click Delete, and then click the option that you want. You can also right-click a selection of 

rows or columns and then click Delete. 

3. If you are deleting a cell or a range of cells, in the Delete dialog box, click Shift cells left, Shift cells up,  

         Entire row, or Entire column. 

             If you are deleting rows or columns, other rows or columns automatically shift up or to the left. 
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Tips     

To quickly repeat deleting cells, rows, or columns, select the next cells, rows, or columns, and then press CTRL+Y. 

If needed, you can restore deleted data immediately after you delete it. On the Quick Access Toolbar, click Undo Delete, or press 

CTRL+Z. 

 NOTES  

Pressing DELETE deletes the contents of the selected cells only, not the cells themselves. 

Excel keeps formulas up to date by adjusting references to the shifted cells to reflect their new locations. However, a formula that 

refers to a deleted cell displays the #REF! error value. 

Wrap text automatically 

1. In a worksheet, select the cells that you want to format. 

2. On the Home tab, in the Alignment group, click Wrap Text . 

 

 NOTES  

Data in the cell wraps to fit the column width. When you change the column width, data wrapping adjusts automatically. 

If all wrapped text is not visible, it may be because the row is set to a specific height.  

How to adjust the row height 

1. Select the cell or range for which you want to adjust the row height. 

2. On the Home tab, in the Cells group, click Format. 

3. Under Cell Size , do one of the following: 

 To automatically adjust the row height, click AutoFit Row Height. 

 To specify a row height, click Row Height, and then type the row height that you want in the  

              Row height box. 
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Find or replace text and numbers on a worksheet 

________________________________________________________________ 

Show All 

1. In a worksheet, click any cell  

2. On the Home tab, in the Editing group, click Find & Select. 

 

         To find text or numbers, click Find. 

3. In the Find what box, type the text or numbers that you want to search for, or click the arrow in the Find what box, and then  

         click a recent search in the list.  

You can use wildcard characters, such as an asterisk (*) or a question mark (?), in your search criteria: 

 Use the asterisk to find any string of characters. For example, s*d finds "sad" and "started".  

 Use the question mark to find any single character. For example, s?t finds "sat" and "set". 

 TIP   You can find asterisks, question marks, and tilde characters (~) in worksheet data by preceding them with a tilde 

character in the Find what box. For example, to find data that contains "?", you would type ~? as your search criteria. 

5. Click Options to further define your search, and then do any of the following: 

 To search for data in a worksheet or in an entire workbook, in the Within box, select Sheet or Workbook. 

 To search for data in specific rows or columns, in the Search box, click By Rows or By Columns. 

 To search for data with specific details, in the Look in box, click Formulas, Values, or Comments. 

 To search for case-sensitive data, select the Match case check box. 

 To search for cells that contain just the characters that you typed in the Find what box, select the Match entire cell 

                        contents check box. 

6. To find text or numbers, click Find All or Find Next. 

 TIP   When you click Find All, every occurrence of the criteria that you are searching for will be listed, and you can 

make a cell active by clicking a specific occurrence in the list. You can sort the results of a Find All search by 

clicking a column heading. 

TIPS 
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Insert or delete a drop-down list 

_______________________________________________________ 

To make data entry easier in Excel, or to limit entries to certain items that you define, you can create 

a drop-down list of valid entries that is compiled from cells elsewhere in the workbook. When you 

create a drop-down list for a cell, it displays an arrow in that cell. To enter information in that cell, 

click the arrow, and then click the entry that you want. 

To create a drop-down list from a range of cells, use the Data Validation command in the Data 

Tools group on the Data tab. 

1. To create a list of valid entries for the drop-down list, type the entries in a single column or row without blank  cells. For 

example: 

  A 

1 Sales 

2 Finance 

3 R&D 

4 IT 

2.  NOTE   You may want to sort the data in the order that you want it to appear in the drop-down list. 

3. If you want to use another worksheet, type the list on that worksheet, and then define a name for the list. 

How to define a name 

1. Select the cell, range of cells, or nonadjacent selections that you want to name. 

2. Click the Name box at the left end of the formula bar.  

3. Type the name for the cells, for example, ValidDepts. 

4. Press ENTER. 

4. Select the cell where you want the drop-down list. 

5. On the Data tab, in the Data Tools group, click Data Validation. 

 

Issue: The Data Validation command is unavailable. 

6. In the Data Validation dialog box, click the Settings tab. 
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7. In the Allow box, click List. 

8. To specify the location of the list of valid entries, do one of the following: 

 If the list is in the current worksheet, enter a reference to your list in the Source box. 

 If the list is on a different worksheet, enter the name that you defined for your list in the Source box. 

In both cases, make sure that the reference or name is preceded with an equal sign (=). For example, enter =ValidDepts.  

9. Make sure that the In-cell dropdown check box is selected. 

10. To specify whether the cell can be left blank, select or clear the Ignore blank check box. 

11. Optionally, display an input message when the cell is clicked. 

 NOTES  

To delete a drop down list, select the cell with the list. Click the Data tab, and then in the Data Group, click Data Validation. In the 

Data Validation dialog box, click the Settings tab, and then click Clear All. Learn more about removing data validation. 

The width of the drop-down list is determined by the width of the cell that has the data validation. You may need to adjust the width 

of that cell to prevent truncating the width of valid entries that are wider than the width of the drop-down list. 

 The maximum number of entries that you can have in a drop-down list is 32,767. 

 If the validation list is on another worksheet and you want to prevent users from seeing it or making changes, consider hiding 

and protecting that worksheet. 

 

Create a hyperlink to a specific location in a workbook 

To link to a location in the current workbook or another workbook, you can either define a name for the destination cells or use a cell 

reference. 

1. To use a name, you must name the destination cells in the destination workbook.  

How to name a cell or a range of cells 

1. Select the cell, range of cells, or nonadjacent selections that you want to name. 

2. Click the Name box at the left end of the formula bar .  

3. In the Name box, type the name for the cells, and then press ENTER. 

2. On a worksheet of the source workbook, click the cell where you want to create a hyperlink. 
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 TIP   You can also select an object, such as a picture or an element in a chart, that you want to use to represent the 

hyperlink. 

On the Insert tab, in the Links group, click Hyperlink. 

 

 TIP    You can also right-click the cell or object and then click Hyperlink on the shortcut menu, or you can press CTRL+K. 

3. Under Link to, do one of the following: 

    In the list under Defined Names, click the name that represents the cells that you want to link to, and then click OK. 

5. In the Text to display box, type the text that you want to use to represent the hyperlink. 

6. To display helpful information when you rest the pointer on the hyperlink, click ScreenTip, type the text that you want in the  

         ScreenTip text box, and then click OK. 

 

Apply filter 

 

1. Select the Data tab, click the Filter command. A drop-down arrow will appear in the header cell for each 
column. ... 

2. Click the drop-down arrow for the column you want to filter. ... 

3. The Filter menu will appear. 

4. Check or uncheck the boxes depending on the data you want to filter, or type a word/phrase into the 
search box, then click OK. ... 

5. The new filter will be applied. 

 


